通过注册表读取程序的路径

不凡 962 2
淘宝购物先领券,更省钱

教程简介

Windows平台的程序在运行的时候会在注册表添加程序的路径,在易语言可以通过注册表读取程序的路径。

注册表路径:HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

程序的描述

根据程序描述返回路径的代码

以下代码需要引用精易模块:http://ec.125.la/

.版本 2

.子程序 根据程序描述返回路径, 文本型
.参数 程序描述, 文本型
.局部变量 注册表操作, 注册表操作
.局部变量 键名数组, 文本型, , "0"
.局部变量 键值数组, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 返回值, 文本型

.计次循环首 (注册表操作.枚举键名 (“HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache”, 键名数组, 键值数组, ), i)
    .如果真 (到文本 (键值数组 [i]) = 程序描述)
        返回值 = 返回值 + 键名数组 [i]
    .如果真结束

.计次循环尾 ()
返回 (返回值)

实例代码

编辑框1.内容 = 根据程序描述返回路径 (“WeChat”)

效果截图

标签: 注册表 路径 精易模块

发表评论 (已有2条评论)

您需要 登录账户 后才能发表评论

评论列表

2020-06-15 03:13:32

更多的不是应该把注册表操作仔细讲讲吗,直接丢精益模块可不好。

2020-06-15 07:18:03

@访客 忘了加上精易模块,我用精易模块习惯了,精易官方有模块源码,可以看注册表操作的代码。