不凡博客(Bufanz.com)

业务范围

网站搭建、优化、故障排查。
电脑故障排查、删除弹窗广告、重装系统、优化系统
32624142(请注明来意)
首页 > 易语言 > 正文

易语言通过注册表读取程序的路径

易语言 | 2020年06月14日08:56:05

云闪付,新人注册领券5元话费券10元生活、购物券

教程简介

Windows平台的程序在运行的时候会在注册表添加程序的路径,在易语言可以通过注册表读取程序的路径。

注册表路径:HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

易语言通过注册表读取程序的路径

程序的描述

易语言通过注册表读取程序的路径

根据程序描述返回路径的代码

以下代码需要引用精易模块:http://ec.125.la/

.版本 2
.子程序 根据程序描述返回路径, 文本型
.参数 程序描述, 文本型
.局部变量 注册表操作, 注册表操作
.局部变量 键名数组, 文本型, , "0"
.局部变量 键值数组, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 返回值, 文本型
.计次循环首 (注册表操作.枚举键名 (“HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache”, 键名数组, 键值数组, ), i)
.如果真 (到文本 (键值数组 [i]) = 程序描述)
返回值 = 返回值 + 键名数组 [i]
.如果真结束
.计次循环尾 ()
返回 (返回值)

实例代码

编辑框1.内容 = 根据程序描述返回路径 (“WeChat”)

效果截图

易语言通过注册表读取程序的路径

淘宝购物先领券,更省钱

本文标题:易语言通过注册表读取程序的路径

本文链接:https://bufanz.com/post/45.html

版权声明:本文章是 不凡博客(Bufanz.com) 的原创文章,未经允许请勿转载本文章!