不凡博客(Bufanz.com)
使用同款主题的其他站长,请别复制我的主题样式,自己动手修改,可以换其它颜色,谢谢!
32624142(注明来意)

通过注册表读取程序的路径

易语言教程 | 2020年06月14日08:56:05 | 阅读:2058 | 评论:2

腾讯云轻量服务器

教程简介

Windows平台的程序在运行的时候会在注册表添加程序的路径,在易语言可以通过注册表读取程序的路径。

注册表路径:HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

通过注册表读取程序的路径

程序的描述

通过注册表读取程序的路径

根据程序描述返回路径的代码

以下代码需要引用精易模块:http://ec.125.la/

.版本 2
.子程序 根据程序描述返回路径, 文本型
.参数 程序描述, 文本型
.局部变量 注册表操作, 注册表操作
.局部变量 键名数组, 文本型, , "0"
.局部变量 键值数组, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 返回值, 文本型
.计次循环首 (注册表操作.枚举键名 (“HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache”, 键名数组, 键值数组, ), i)
.如果真 (到文本 (键值数组 [i]) = 程序描述)
返回值 = 返回值 + 键名数组 [i]
.如果真结束
.计次循环尾 ()
返回 (返回值)

实例代码

编辑框1.内容 = 根据程序描述返回路径 (“WeChat”)

效果截图

通过注册表读取程序的路径

淘宝购物先领券,更省钱

本文标题:通过注册表读取程序的路径

本文链接:https://bufanz.com/post/45.html

温馨提示:本文是作者 不凡 的原创文章,转载请注明出处和附带本文链接!

网友点评 展开评论

Tange 更多的不是应该把注册表操作仔细讲讲吗,直接丢精益模块可不好。
不凡 回复 Tange: 忘了加上精易模块,我用精易模块习惯了,精易官方有模块源码,可以看注册表操作的代码。

本文已有2位网友发表了点评 - 欢迎您